Bug 46690 - REGRESSION (r68338): JavaScript error on PowerPC only (crashes on Interpreter built for x86_64)
Summary: REGRESSION (r68338): JavaScript error on PowerPC only (crashes on Interpreter...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://trailers.apple.com/trailers/pa...
Keywords: InRadar, NeedsReduction
: 46916 (view as bug list)
Depends on: 46572
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-27 19:48 PDT by Edward Sabol
Modified: 2010-10-05 01:29 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.60 KB, patch)
2010-10-04 17:24 PDT, Oliver Hunt
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Sabol 2010-09-27 19:48:53 PDT
When visiting http://trailers.apple.com/trailers/paramount/truegrit/ with the latest Webkit Nightly (r68419), I noticed that the "Info" button and the "Watch Now" menu did not render. The Error console reports:

"TypeError: Result of expression 'arguments' [undefined] is not an object" in /trailers/global/scripts/lib/scriptaculous.js:97

No such error occurs when you use r68419 on Intel. (Both 10.5.8 and 10.6.x were tested with extensions turned off.) I tested the previous nightly build (r68242) on PowerPC and no error there either, so the regression must have occurred between r68243 and r68419. I can't really narrow it down any further than that.
Comment 1 Deirdre Saoirse Moen 2010-09-27 19:57:59 PDT
<rdar://problem/8485090>
Comment 2 David Kilzer (:ddkilzer) 2010-09-28 17:00:45 PDT
Using git-bisect, I tracked this down to r68338.  (Building the Interpreter for x86_64 causes a crash when loading the same page.)

<http://trac.webkit.org/changeset/68338>
Comment 3 Geoffrey Garen 2010-09-29 10:11:37 PDT
Thanks, Dave!
Comment 4 Kevin M. Dean 2010-10-01 09:14:11 PDT
*** Bug 46916 has been marked as a duplicate of this bug. ***
Comment 5 Kevin M. Dean 2010-10-01 09:16:25 PDT
Here's another page with the same issue from my Bug 46916.

http://www.animepaper.net/gallery/wallpapers/Latest/item107844/
I see the same problem at this link and others on this site where a large picture and following comments are not shown as expected.
Comment 6 Oliver Hunt 2010-10-04 17:24:41 PDT
Created attachment 69725 [details]
Patch
Comment 7 Oliver Hunt 2010-10-04 19:12:35 PDT
Comment on attachment 69725 [details]
Patch

forgot to land this apparently, using cq to do it for me
Comment 8 WebKit Commit Bot 2010-10-05 01:29:06 PDT
Comment on attachment 69725 [details]
Patch

Clearing flags on attachment: 69725

Committed r69096: <http://trac.webkit.org/changeset/69096>
Comment 9 WebKit Commit Bot 2010-10-05 01:29:11 PDT
All reviewed patches have been landed.  Closing bug.