Bug 46308 - [Qt] Message posted in one iframe textbox is not displayed in the other iframe textbox.
Summary: [Qt] Message posted in one iframe textbox is not displayed in the other ifram...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: 528+ (Nightly build)
Hardware: S60 Hardware S60 3rd edition
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-22 14:12 PDT by Prasad
Modified: 2011-01-28 17:55 PST (History)
1 user (show)

See Also:


Attachments
1st iFrame file (1.19 KB, text/html)
2010-09-22 14:16 PDT, Prasad
no flags Details
2nd iFrame file (1.18 KB, text/html)
2010-09-22 14:16 PDT, Prasad
no flags Details
Test case (1.52 KB, text/html)
2010-09-22 14:17 PDT, Prasad
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Prasad 2010-09-22 14:12:53 PDT
Message posted in one iframe textbox is not displayed in the other iframe textbox which is accessed over the network.

Steps to reproduce: 
1. Launch the HTML page "testcase2.html".
2. Enter some text in the text field in the first window on left "Window: iframe3.html".

Expected:
Same text entered in the first text field should be displayed in the second window text field "Window: iframe4.html"

Actual:
Text entered in the first text field is NOT displayed in the second text field "Window: iframe4.html"

Note:
The second window text field "iframe4.html" has to be accessed over the network and Testcase2.html has to be edited accordingly.
[var url2 = 'iframe4.html'; //note: this html file has to be accessed over the network]

Additional Info:

• Hardware: N8
• Webkit version: 2.1
• Qt version: 4.7
Comment 1 Prasad 2010-09-22 14:16:32 PDT
Created attachment 68439 [details]
1st iFrame file
Comment 2 Prasad 2010-09-22 14:16:58 PDT
Created attachment 68440 [details]
2nd iFrame file
Comment 3 Prasad 2010-09-22 14:17:35 PDT
Created attachment 68442 [details]
Test case
Comment 4 Benjamin Poulain 2011-01-28 17:55:09 PST
Please follow http://trac.webkit.org/wiki/QtWebKitBugs when reporing bug here.

I close since I cannot reproduce the bug (on Linux) with trunk. Was this S60 specific?