Bug 46276 - Web Inspector: export raw data from Timeline panel.
Summary: Web Inspector: export raw data from Timeline panel.
Status: RESOLVED DUPLICATE of bug 64601
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Ilya Tikhonovsky
URL:
Keywords:
: 46246 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-22 10:15 PDT by Ilya Tikhonovsky
Modified: 2011-08-03 08:28 PDT (History)
10 users (show)

See Also:


Attachments
screenshot of the button. Need a UI guy for it. (4.00 KB, image/png)
2010-09-22 10:19 PDT, Ilya Tikhonovsky
no flags Details
[patch] initial version. (10.17 KB, patch)
2010-09-22 10:21 PDT, Ilya Tikhonovsky
pfeldman: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Tikhonovsky 2010-09-22 10:15:42 PDT
http://www.chromeboard.com/showthread.php?p=114349
Comment 1 Ilya Tikhonovsky 2010-09-22 10:19:29 PDT
Created attachment 68388 [details]
screenshot of the button. Need a UI guy for it.
Comment 2 Ilya Tikhonovsky 2010-09-22 10:21:05 PDT
Created attachment 68390 [details]
[patch] initial version.

has binary data.
Need a design for 'export raw data' button.
Comment 3 Yury Semikhatsky 2010-09-23 00:24:12 PDT
Comment on attachment 68390 [details]
[patch] initial version.

View in context: https://bugs.webkit.org/attachment.cgi?id=68390&action=review

> WebCore/inspector/front-end/TimelinePanel.js:88
> +    this._exportToFileTitleText = WebInspector.UIString("Export to file");

Why not just use it inplace?

> WebCore/inspector/front-end/TimelinePanel.js:297
> +        objectForExport.version = /AppleWebKit\/([^ ]+)/.exec(window.navigator.userAgent)[0];

What is the version format? Is it consistent between browsers?
Comment 4 Pavel Feldman 2010-09-23 01:26:36 PDT
Comment on attachment 68390 [details]
[patch] initial version.

View in context: https://bugs.webkit.org/attachment.cgi?id=68390&action=review

I am against adding this button until the format being exported is documented. At least on the Web Inspector wiki. If you'd like to push this functionality faster, make Ctrl+C export the data into the clipboard.

>> WebCore/inspector/front-end/TimelinePanel.js:297
>> +        objectForExport.version = /AppleWebKit\/([^ ]+)/.exec(window.navigator.userAgent)[0];
> 
> What is the version format? Is it consistent between browsers?

We need a format version here, not the webkit version.

> WebCore/inspector/front-end/inspector.css:3762
> +    -webkit-mask-image: url(Images/exportButtonGlyph.png);

Need a better icon prior to landing.
Comment 5 Pavel Feldman 2010-09-23 06:37:40 PDT
*** Bug 46246 has been marked as a duplicate of this bug. ***
Comment 6 Ilya Tikhonovsky 2011-08-03 08:28:14 PDT

*** This bug has been marked as a duplicate of bug 64601 ***