Bug 46248 - [Qt] Fix bugs when building WebKit with Qt 4.7.1
: [Qt] Fix bugs when building WebKit with Qt 4.7.1
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To:
:
: Qt, QtTriaged, Regression
: 46249 46250 46251 47073 50144 50145 50146 50147 51819
:
  Show dependency treegraph
 
Reported: 2010-09-22 01:52 PST by
Modified: 2012-07-23 00:23 PST (History)


Attachments
migrating to Qt 4.7.1 (613.82 KB, patch)
2010-11-29 07:15 PST, Csaba Osztrogonác
no flags Review Patch | Details | Formatted Diff | Diff
proposed patch for QtWebKit-2.1.x branch (578.48 KB, patch)
2011-03-23 08:11 PST, Csaba Osztrogonác
no flags Review Patch | Details | Formatted Diff | Diff
proposed patch for QtWebKit-2.1 and 2.1.x branches (37.14 KB, patch)
2011-03-23 19:55 PST, Csaba Osztrogonác
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-09-22 01:52:08 PST
Nokia released Qt  4.7.0, but now ~140 layout tests
fail when building WebKit trunk with Qt 4.7.0. 
(Qt buildbots use Qt 4.6.2 on build.webkit.org now.)

"x86-32 Linux Qt-4.7.0 Release" buildbot here:
http://webkit.sed.hu/buildbot/waterfall

Most of them (~120-130) only need a rebaseline,
but there are ~10-20 real bug should be fixed.

We are going to set Qt buildbots on build.webkit.org 
to use Qt 4.7.0 after this meta bug fixed.
------- Comment #1 From 2010-10-29 09:30:14 PST -------
*** Bug 48633 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2010-11-29 07:15:20 PST -------
Created an attachment (id=75024) [details]
migrating to Qt 4.7.1

I think it's time to migrating Qt 4.7.1.

The proposed patch:
- add failing tests to the Skipped list
- remove passing tests from the Skipped list
- update expected files related to the migration (4.6.3 -> 4.7.1)
------- Comment #3 From 2010-11-30 00:06:59 PST -------
(From update of attachment 75024 [details])
Awesome, go for it :)
------- Comment #4 From 2010-11-30 02:55:01 PST -------
(From update of attachment 75024 [details])
Landed in http://trac.webkit.org/changeset/72896

Leave the bug open until depending bugs are fixed.
------- Comment #5 From 2011-03-23 08:11:58 PST -------
Created an attachment (id=86619) [details]
proposed patch for QtWebKit-2.1.x branch

I merged http://trac.webkit.org/changeset/72896 to QtWebKit-2.1.x branch
without Skipped list modifications. ( I had to remove ~10 expected update
from the original patch, because they are already updated in the branch.)

Laszlo, Andreas, rs=you? to push it to the QtWebKit-2.1.x and 2.1 branches?
------- Comment #6 From 2011-03-23 08:13:12 PST -------
rs=me
------- Comment #7 From 2011-03-23 08:59:49 PST -------
Cherry-picked into qtwebkit-2.1 branch with commit 3f3d191ac9dca758cdca75b77f0337f4e5b1e37f <http://gitorious.org/webkit/qtwebkit/commit/3f3d191ac9dca758cdca75b77f0337f4e5b1e37f>
------- Comment #8 From 2011-03-23 09:00:16 PST -------
Also merged to qtwebkit-2.1.x branch.
------- Comment #9 From 2011-03-23 19:55:38 PST -------
Created an attachment (id=86736) [details]
proposed patch for QtWebKit-2.1 and 2.1.x branches

Merging http://trac.webkit.org/changeset/72896 to QtWebKit-2.1 QtWebKit-2.1.x  branches - step 2.

- I added tests to the Skipped list, which passed with Qt 4.6, but fail with Qt 4.7.2 .
- I removed tests from the Skipped list, which failed with Qt 4.6, but pass now.

rs=?
------- Comment #10 From 2011-03-24 05:16:02 PST -------
(In reply to comment #9)
> Created an attachment (id=86736) [details] [details]
> proposed patch for QtWebKit-2.1 and 2.1.x branches
> 
> Merging http://trac.webkit.org/changeset/72896 to QtWebKit-2.1 QtWebKit-2.1.x  branches - step 2.
> 
> - I added tests to the Skipped list, which passed with Qt 4.6, but fail with Qt 4.7.2 .
> - I removed tests from the Skipped list, which failed with Qt 4.6, but pass now.
> 
> rs=?

rs=me, yo!
------- Comment #11 From 2011-03-24 05:47:41 PST -------
Cherry-picked into qtwebkit-2.1 branch with commit f3c5fd7b5e2bb27edd8e0afc2b16b69a7514c301 <http://gitorious.org/webkit/qtwebkit/commit/f3c5fd7b5e2bb27edd8e0afc2b16b69a7514c301>

And also merged to qtwebkit-2.1.x branch.
------- Comment #12 From 2012-07-19 07:23:28 PST -------
Closing this bug as it seems work is completed and we don't support Qt 4.7 anymore anyway :)
------- Comment #13 From 2012-07-21 13:15:28 PST -------
(In reply to comment #12)
> Closing this bug as it seems work is completed and we don't support Qt 4.7 anymore anyway :)

I don't think if it is completed, because bugs on depends 
on list are still valid with Qt 4.8 and Qt 5.0.
------- Comment #14 From 2012-07-23 00:23:22 PST -------
True, those bugs are still open. But they are not necessarily directly related to Qt 4.7 I think.