Bug 45760 - PrettyPatch doesn't handle UTF-8 characters correctly
Summary: PrettyPatch doesn't handle UTF-8 characters correctly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-14 09:49 PDT by Patrick R. Gansterer
Modified: 2013-07-09 10:33 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.35 KB, patch)
2013-07-09 10:10 PDT, Martin Robinson
aroben: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick R. Gansterer 2010-09-14 09:49:29 PDT
When you open the following patch you see wrong characters at "LayoutTests/fast/dom/Window/atob-btoa-expected.txt":
https://bugs.webkit.org/attachment.cgi?id=66276&action=review

The following path looks correct, but doesn't apply via svn-apply:
https://bugs.webkit.org/attachment.cgi?id=66070&action=review

It seams that PrettyPatch reads ASCII instead of UTF-8.
Comment 1 Martin Robinson 2013-07-09 10:07:56 PDT
*** Bug 75394 has been marked as a duplicate of this bug. ***
Comment 2 Martin Robinson 2013-07-09 10:10:45 PDT
Created attachment 206334 [details]
Patch
Comment 3 Adam Roben (:aroben) 2013-07-09 10:22:04 PDT
Comment on attachment 206334 [details]
Patch

r=me
Comment 4 Martin Robinson 2013-07-09 10:33:22 PDT
Committed r152496: <http://trac.webkit.org/changeset/152496>