Bug 45708 - Rename GraphicsContext3D::WebGLEnumType
Summary: Rename GraphicsContext3D::WebGLEnumType
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P3 Normal
Assignee: Zhenyao Mo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-13 13:51 PDT by Kenneth Russell
Modified: 2011-02-08 17:47 PST (History)
4 users (show)

See Also:


Attachments
Patch (2.28 KB, patch)
2011-02-08 16:21 PST, Zhenyao Mo
no flags Details | Formatted Diff | Diff
Patch (2.27 KB, patch)
2011-02-08 17:33 PST, Zhenyao Mo
kbr: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2010-09-13 13:51:33 PDT
Since WebGL is no longer the sole consumer of GraphicsContext3D, the WebGLEnumType in GC3D should be renamed in the case where clients need to refer specifically to the enum values provided by GC3D. EnumType would be sufficient since it's scoped within the GC3D class.
Comment 1 Zhenyao Mo 2010-10-28 17:24:23 PDT
Maybe GLEnumType?
Comment 2 Kenneth Russell 2010-11-01 14:18:56 PDT
(In reply to comment #1)
> Maybe GLEnumType?

No reason. Again, the type name is scoped within GraphicsContext3D.
Comment 3 Zhenyao Mo 2011-02-08 16:19:15 PST
I really enjoy grabbing easy-to-fix bugs from others :)
Comment 4 Zhenyao Mo 2011-02-08 16:21:27 PST
Created attachment 81713 [details]
Patch
Comment 5 Zhenyao Mo 2011-02-08 16:30:38 PST
Actually now I think about it again, maybe we could just go with anonymous enums?  Basically we want people to use GC3Denum type instead of GraphicsContext3D::EnumType.
Comment 6 Kenneth Russell 2011-02-08 17:15:10 PST
(In reply to comment #5)
> Actually now I think about it again, maybe we could just go with anonymous enums?  Basically we want people to use GC3Denum type instead of GraphicsContext3D::EnumType.

Sure, that sounds fine. It's impossible in the OpenGL API to have distinct enum types for different uses, because there's overloading of some of the enums in different entry points, so there really isn't any value in naming the enum.
Comment 7 Zhenyao Mo 2011-02-08 17:33:20 PST
Created attachment 81724 [details]
Patch
Comment 8 Kenneth Russell 2011-02-08 17:37:48 PST
Comment on attachment 81724 [details]
Patch

Looks fine.
Comment 9 Zhenyao Mo 2011-02-08 17:47:04 PST
Committed r77999: <http://trac.webkit.org/changeset/77999>