RESOLVED FIXED 45555
Speed up deserialisation of strings
https://bugs.webkit.org/show_bug.cgi?id=45555
Summary Speed up deserialisation of strings
Oliver Hunt
Reported 2010-09-10 11:56:28 PDT
Speed up deserialisation of strings
Attachments
Patch (7.77 KB, patch)
2010-09-10 12:05 PDT, Oliver Hunt
darin: review+
Oliver Hunt
Comment 1 2010-09-10 12:05:13 PDT
Darin Adler
Comment 2 2010-09-10 12:13:06 PDT
Comment on attachment 67220 [details] Patch > + UString m_ident; > + JSValue m_string; These are confusing names. The string is named "ident" (unnecessary abbreviation), and the JSValue is named string! How about naming one thing m_string and the other m_stringAsJSValue or m_stringWrappedInJSValue or something like that. Also, I think the function name jsString is not so great, but I don’t have a better suggestion. Maybe something with the word "wrap" in it. > - bool readStringData(Identifier& ident) > + bool readStringData(CachedString*& ident) You should name this string, not ident. > - bool readStringData(Identifier& ident, bool& wasTerminator) > + bool readStringData(CachedString*& ident, bool& wasTerminator) And this. > - Identifier ident; > + CachedString* ident; And this.
Early Warning System Bot
Comment 3 2010-09-10 12:13:51 PDT
Eric Seidel (no email)
Comment 4 2010-09-10 12:24:03 PDT
Oliver Hunt
Comment 5 2010-09-10 12:53:11 PDT
WebKit Review Bot
Comment 6 2010-09-10 13:02:49 PDT
http://trac.webkit.org/changeset/67222 might have broken Qt Linux Release minimal
Note You need to log in before you can comment on or make changes to this bug.