Bug 45241 - [EFL] REGRESSION(66794) Need to fix build break.
Summary: [EFL] REGRESSION(66794) Need to fix build break.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-05 05:42 PDT by Ryuan Choi
Modified: 2010-09-06 10:30 PDT (History)
6 users (show)

See Also:


Attachments
Patch (3.98 KB, patch)
2010-09-05 05:49 PDT, Ryuan Choi
no flags Details | Formatted Diff | Diff
Patch (4.04 KB, patch)
2010-09-06 08:18 PDT, Ryuan Choi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryuan Choi 2010-09-05 05:42:39 PDT
Implementation of FrameLoaderClient for new feature make build break.

/workspace/WebKit_EFL/WebKit/WebKit/efl/WebCoreSupport/FrameLoaderClientEfl.cpp: In member function ‘virtual WTF::PassRefPtr<WebCore::FrameNetworkingContext> WebCore::FrameLoaderClientEfl::createNetworkingContext()’:
/workspace/WebKit_EFL/WebKit/WebKit/efl/WebCoreSupport/FrameLoaderClientEfl.cpp:951:12: error: ‘create’ is not a member of ‘WebCore::FrameNetworkingContext’
/workspace/WebKit_EFL/WebKit/WebKit/efl/WebCoreSupport/FrameLoaderClientEfl.cpp:951:48: error: ‘m_webFrame’ was not declared in this scope
/workspace/WebKit_EFL/WebKit/WebKit/efl/WebCoreSupport/FrameLoaderClientEfl.cpp:951:64: error: ‘core’ was not declared in this scope
make[2]: *** [WebKit/CMakeFiles/ewebkit.dir/efl/WebCoreSupport/FrameLoaderClientEfl.cpp.o] 오류 1
make[2]: *** 끝나지 않은 작업을 기다리고 있습니다....
make[1]: *** [WebKit/CMakeFiles/ewebkit.dir/all] 오류 2
make: *** [all] 오류 2
Comment 1 Ryuan Choi 2010-09-05 05:49:54 PDT
Created attachment 66597 [details]
Patch
Comment 2 Antonio Gomes 2010-09-05 11:48:29 PDT
Comment on attachment 66597 [details]
Patch

It needs a review. Diego what do you think?
Comment 3 Diego Gonzalez 2010-09-06 07:26:57 PDT
(In reply to comment #2)
> (From update of attachment 66597 [details])
> It needs a review. Diego what do you think?

Seems fine!
Comment 4 Lucas De Marchi 2010-09-06 07:44:18 PDT
Comment on attachment 66597 [details]
Patch

> Index: WebKit/efl/ChangeLog
> ===================================================================
> --- WebKit/efl/ChangeLog	(revision 66800)
> +++ WebKit/efl/ChangeLog	(working copy)
> @@ -1,3 +1,20 @@
> +2010-09-05  Ryuan Choi  <ryuan.choi@samsung.com>
> +
> +        Unreviewed build fix.
> +
> +        [EFL] REGRESSION(66794) Need to fix build break.
> +        https://bugs.webkit.org/show_bug.cgi?id=45241
> +
> +        Add dummy class(FrameNetworkingContextEfl) like GTK+ port and implement
> +        as EFL style.

Since you copied from GTK, I think you should keep their copyright on WebKit/efl/WebCoreSupport/FrameNetworkingContextEfl.h
Comment 5 Ryuan Choi 2010-09-06 08:18:44 PDT
Created attachment 66646 [details]
Patch
Comment 6 WebKit Commit Bot 2010-09-06 10:30:48 PDT
Comment on attachment 66646 [details]
Patch

Clearing flags on attachment: 66646

Committed r66839: <http://trac.webkit.org/changeset/66839>
Comment 7 WebKit Commit Bot 2010-09-06 10:30:53 PDT
All reviewed patches have been landed.  Closing bug.