Bug 44740 - Please add registerProtocolHandler and registerContentHandler
: Please add registerProtocolHandler and registerContentHandler
Status: RESOLVED DUPLICATE of bug 73177
Product: WebKit
Classification: Unclassified
Component: WebCore Misc.
: 528+ (Nightly build)
: Macintosh Intel Mac OS X 10.6
: P2 Enhancement
Assigned To: Nobody
http://www.w3.org/TR/html5/timers.htm...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-26 18:57 PDT by Rodger Combs
Modified: 2012-01-20 18:01 PST (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodger Combs 2010-08-26 18:57:59 PDT
registerProtocolHandler and registerContentHandler, as defined in the HTML5 spec, should be supported by WebKit.
Comment 1 Peter Beverloo 2010-11-11 13:40:47 PST
Both methods landed in r50477, following bug 29651. This exposed the methods, but as no port implemented them, they were rolled out in r62834.

More recently, James Kozianski said he would have a look at implementing this. I've added him to the cc list.
Comment 2 James Kozianski 2011-02-19 22:54:24 PST
JS bindings for registerProtocolHandler were landed in bug 44740, and I'm working on an implementation for Chromium here http://codereview.chromium.org/6410115/
Comment 3 Dongwoo Joshua Im (dwim) 2011-11-27 18:13:57 PST
Is there any way to roll the 'registerContentHandler' in again?
I will implement EFL port layer for the API.

Please let me know how to roll the API in again.


Thanks.
Comment 4 Eric Seidel 2012-01-20 18:01:13 PST

*** This bug has been marked as a duplicate of bug 73177 ***