Bug 44697 - [Qt] tst_QWebFrame::connectAndDisconnect() fails on WebKit trunk because __qt_sender__ is never set
Summary: [Qt] tst_QWebFrame::connectAndDisconnect() fails on WebKit trunk because __qt...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Major
Assignee: Kent Hansen
URL:
Keywords: Qt, QtTriaged
: 41066 (view as bug list)
Depends on:
Blocks: 44675
  Show dependency treegraph
 
Reported: 2010-08-26 11:16 PDT by Benjamin Poulain
Modified: 2010-09-09 13:52 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.23 KB, patch)
2010-09-07 02:07 PDT, Kent Hansen
akling: review+
kent.hansen: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2010-08-26 11:16:16 PDT
The test tst_QWebFrame::connectAndDisconnect() fails on recent WebKit. This test does not fail on QtWebKit 2.0, but it does fail on WebKit trunk and WebKit 2.1.

The outcome of the test is the following: 
FAIL!  : tst_QWebFrame::connectAndDisconnect() Compared values are not the same
   Actual (evalJS("signalSender")): undefined
   Expected (evalJS("myObject")): 
   Loc: [/home/ikipou/dev/webkit/qtwebkit/WebKit/qt/tests/qwebframe/tst_qwebframe.cpp(1488)]

It seems __qt_sender__ is never set in the context of the function call.
Comment 1 Andreas Kling 2010-08-31 16:21:25 PDT
*** Bug 41066 has been marked as a duplicate of this bug. ***
Comment 2 Kent Hansen 2010-09-07 02:07:12 PDT
Created attachment 66695 [details]
Patch
Comment 3 Andreas Kling 2010-09-07 04:01:20 PDT
Comment on attachment 66695 [details]
Patch

r=me
Comment 4 Kent Hansen 2010-09-07 04:16:22 PDT
Committed r66875: <http://trac.webkit.org/changeset/66875>
Comment 5 Ademar Reis 2010-09-09 13:52:18 PDT
Revision r66875 cherry-picked into qtwebkit-2.1 with commit a64f996864afde31b00d787522d47d1222a8f756