Bug 4450 - HTMLCollections leak their info
Summary: HTMLCollections leak their info
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P2 Normal
Assignee: Maciej Stachowiak
URL:
Keywords:
: 3856 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-15 23:05 PDT by Maciej Stachowiak
Modified: 2005-08-23 13:41 PDT (History)
1 user (show)

See Also:


Attachments
fix for the leak (2.59 KB, patch)
2005-08-15 23:11 PDT, Maciej Stachowiak
sullivan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2005-08-15 23:05:05 PDT
HTMLCollections leak the info pointer. This can easily be observed by running Safari with 
MallocStackLogging set to YES, visiting http://www.sony.com , and closing the window. Then run `leaks 
Safari' from the command-line. Many leaks appear, including a large number related to collection info.
Comment 1 Maciej Stachowiak 2005-08-15 23:11:10 PDT
Created attachment 3418 [details]
fix for the leak
Comment 2 John Sullivan 2005-08-16 08:50:14 PDT
Comment on attachment 3418 [details]
fix for the leak

Looks nice and simple.
Comment 3 Darin Adler 2005-08-16 11:16:12 PDT
Comment on attachment 3418 [details]
fix for the leak

The URL in the change log is "post_bug.cgi". Should fix that.

r=me also, by the way
Comment 4 John Sullivan 2005-08-23 13:41:18 PDT
*** Bug 3856 has been marked as a duplicate of this bug. ***