Bug 44419 - WebCore/bridge/jni/v8 does not compile
Summary: WebCore/bridge/jni/v8 does not compile
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-23 06:37 PDT by Iain Merrick
Modified: 2010-08-23 14:52 PDT (History)
3 users (show)

See Also:


Attachments
Patch to make V8 strings compile (4.73 KB, patch)
2010-08-23 06:58 PDT, Iain Merrick
no flags Details | Formatted Diff | Diff
Patch to make V8 strings compile (4.72 KB, patch)
2010-08-23 07:43 PDT, Iain Merrick
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Iain Merrick 2010-08-23 06:37:47 PDT
Some API changes were made to JavaScriptCore/runtime/UString.h in http://trac.webkit.org/changeset/65305. The JSC string implementation (in WebCore/bridge/jni/jsc) was updated, but the v8 string implementation was not updated and no longer compiles.

The UTF8String() method needs to be renamed to utf8().
Comment 1 Iain Merrick 2010-08-23 06:58:13 PDT
Created attachment 65111 [details]
Patch to make V8 strings compile
Comment 2 Steve Block 2010-08-23 07:09:04 PDT
Comment on attachment 65111 [details]
Patch to make V8 strings compile

If you'd like the patch to be reviewed, you should set the r? flag. This will make the patch show up in the review queue and trigger the EWS bots.

As a non-committer, you probably want to set cq? too, to request the reviewer to add the patch to the commit-queue once reviewed.
Comment 3 Steve Block 2010-08-23 07:30:44 PDT
Comment on attachment 65111 [details]
Patch to make V8 strings compile

WebCore/ChangeLog:5
 +          Make V8 string wrappers compatible with JavaScriptCore/runtime/UString.h
I think this title is a little confusing. We're fixing the JNI bridge for V8. The problem is that the declaration of JavaString has been changed but the V8 implementation was not updated. Maybe 'Update JNI bridge for V8 after renaming of JavaString::utf8()'
Comment 4 Iain Merrick 2010-08-23 07:43:26 PDT
Created attachment 65118 [details]
Patch to make V8 strings compile

Modified ChangeLog per steveblock's comment
Comment 5 Steve Block 2010-08-23 07:46:26 PDT
Comment on attachment 65118 [details]
Patch to make V8 strings compile

r=me
Comment 6 WebKit Commit Bot 2010-08-23 14:52:29 PDT
Comment on attachment 65118 [details]
Patch to make V8 strings compile

Clearing flags on attachment: 65118

Committed r65833: <http://trac.webkit.org/changeset/65833>
Comment 7 WebKit Commit Bot 2010-08-23 14:52:34 PDT
All reviewed patches have been landed.  Closing bug.