Bug 44404 - [@font-face] show fallback text after a short time while a font downloads
Summary: [@font-face] show fallback text after a short time while a font downloads
Status: RESOLVED DUPLICATE of bug 25207
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: NeedsRadar
Depends on:
Blocks:
 
Reported: 2010-08-22 21:53 PDT by Paul Irish
Modified: 2010-09-12 22:24 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Irish 2010-08-22 21:53:07 PDT
Example: Go to http://people.mozilla.com/~jkew/woff/udhr-sample/index.html.
Choose the 3rd option for display; it's a *large* font download, so you see a
delay. The text will stay invisible the entire time.

This effect is exacerbated on mobile devices and in low-bandwidth situations, preventing the user from seeing any text.

The solution that's been considered in www-style is to use a fallback font (whatever is next in the stack) after a few seconds if the font hasn't downloaded/isn't ready.

Associated mozilla bug: https://bugzilla.mozilla.org/show_bug.cgi?id=499292

More related detail:
http://www.stevesouders.com/blog/2009/10/13/font-face-and-performance/
http://paulirish.com/2009/fighting-the-font-face-fout/
Comment 1 Yuzo Fujishima 2010-09-12 22:24:05 PDT

*** This bug has been marked as a duplicate of bug 25207 ***