Bug 44387 - Add the blob URL member to FormData
Summary: Add the blob URL member to FormData
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Jian Li
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-21 18:44 PDT by Jian Li
Modified: 2010-08-22 14:38 PDT (History)
5 users (show)

See Also:


Attachments
Proposed Patch (8.22 KB, patch)
2010-08-21 18:52 PDT, Jian Li
jianli: commit-queue-
Details | Formatted Diff | Diff
Proposed Patch (8.21 KB, patch)
2010-08-21 19:32 PDT, Jian Li
fishd: review+
jianli: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jian Li 2010-08-21 18:44:42 PDT
When we add a blob into the FormData in out BlobData model, we're adding the blob URL. We need to add the blob URL member to FormDataElement.
Comment 1 Jian Li 2010-08-21 18:52:33 PDT
Created attachment 65040 [details]
Proposed Patch
Comment 2 WebKit Review Bot 2010-08-21 18:54:38 PDT
Attachment 65040 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebCore/platform/network/FormData.h:79:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
Total errors found: 1 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Jian Li 2010-08-21 19:32:02 PDT
Created attachment 65044 [details]
Proposed Patch

Fix style error.
Comment 4 Darin Fisher (:fishd, Google) 2010-08-21 21:02:22 PDT
Comment on attachment 65044 [details]
Proposed Patch

WebKit/chromium/src/WebHTTPBody.cpp:80
 +      result.fileStart = 0;
nit: these fields exist regardless of whether or not ENABLE(BLOB) is defined,
so they probably should be initialized even when ENABLE(BLOB) is not defined.

otherwise, LG

R=me
Comment 5 Jian Li 2010-08-22 14:38:22 PDT
Committed as http://trac.webkit.org/changeset/65786.