Bug 44316 - [GTK] r65681 broke a couple GTK+ a11y tests
Summary: [GTK] r65681 broke a couple GTK+ a11y tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P3 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords: Gtk, LayoutTestFailure
Depends on: 21834
Blocks: 98347
  Show dependency treegraph
 
Reported: 2010-08-19 18:01 PDT by Martin Robinson
Modified: 2016-04-29 13:28 PDT (History)
10 users (show)

See Also:


Attachments
Patch (13.77 KB, patch)
2016-04-29 12:33 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2010-08-19 18:01:18 PDT
In particular:
platform/gtk/accessibility/object-attributes.html
platform/gtk/accessibility/title-and-alt.html


(01:18:06 PM) eseidel: smfr: understandable.  looking at your diff now
(01:18:36 PM) eseidel: smfr: I wonder if gtk ax code is failing to update layout itself.
(01:18:42 PM) smfr: could be
(01:18:56 PM) eseidel: and was dependant on some previous layout behavior
(01:18:59 PM) smfr: some of the changes seem like preogressions
(01:19:04 PM) smfr: image.description should be AXDescription: Image title attr. Was AXDescription: .
(01:19:40 PM) eseidel: smfr: that looks like its getting the empty string for the description

...I confirmed it was this revision...

(01:54:52 PM) smfr: mrobinson: ok. so someone needs to updateStyle before accessing the Ax info
Comment 1 Martin Robinson 2010-08-19 18:06:31 PDT
Committed r65720: <http://trac.webkit.org/changeset/65720>
Comment 2 Joanmarie Diggs (irc: joanie) 2016-04-29 12:27:34 PDT
Wow. So this is really old. And whatever the original regression is, that is no longer a problem. Yay! That said.... A lot of other things have changed since these were skipped, including:

1. Output of role names has changed
2. Output of attributes has changed (and spits out a lot more)
3. Layout tables are no longer exposed as tables
4. Anonymous blocks are sometimes included in the accessibility tree
5. We have test runner API to get accessible objects by element id

The object-attributes.html test can be unskipped by updating it to take into account the above.

The title-and-alt.html test can be partially fixed in a similar fashion. However, there will still be some failures which fall under the umbrella of bug 157187.

My proposal is that we update both tests, but leave the second one as a failure to be dealt with in bug 157187. Patch shall be forthcoming.
Comment 3 Joanmarie Diggs (irc: joanie) 2016-04-29 12:33:52 PDT
Created attachment 277727 [details]
Patch
Comment 4 WebKit Commit Bot 2016-04-29 13:28:47 PDT
Comment on attachment 277727 [details]
Patch

Clearing flags on attachment: 277727

Committed r200260: <http://trac.webkit.org/changeset/200260>
Comment 5 WebKit Commit Bot 2016-04-29 13:28:54 PDT
All reviewed patches have been landed.  Closing bug.