Bug 44240 - REGRESSION (r62896): Interpreter incorrectly excludes prototype chain when validating put_by_id_transition
: REGRESSION (r62896): Interpreter incorrectly excludes prototype chain when va...
Status: RESOLVED FIXED
: WebKit
JavaScriptCore
: 528+ (Nightly build)
: Macintosh Mac OS X 10.6
: P2 Normal
Assigned To:
:
: InRadar
: 41929
:
  Show dependency treegraph
 
Reported: 2010-08-19 04:41 PST by
Modified: 2010-08-24 10:08 PST (History)


Attachments
Patch (1.60 KB, patch)
2010-08-23 16:51 PST, Oliver Hunt
darin: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-08-19 04:41:25 PST
LayoutTests/fast/js/dictionary-no-cache.html fails using the JSC interpreter, but passes using the JSC JIT.

--- a/LayoutTests/fast/js/dictionary-no-cache-expected.txt
+++ b/LayoutTests/fast/js/dictionary-no-cache-expected.txt
@@ -5,7 +5,7 @@ On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE

 PASS foundNewPrototypeProperty is true
 PASS foundRemovedPrototypeProperty is false
-PASS calledNewPrototypeSetter is true
+FAIL calledNewPrototypeSetter should be true. Was false.
 PASS getTestProperty(test4) is "on prototype"
 PASS getTestProperty(test4) is "on self"
 PASS getTestProperty(test5) is "on prototype's prototype"
------- Comment #1 From 2010-08-19 04:48:05 PST -------
<rdar://problem/8328995>
------- Comment #2 From 2010-08-23 16:32:10 PST -------
*** Bug 44241 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2010-08-23 16:51:37 PST -------
Created an attachment (id=65184) [details]
Patch
------- Comment #4 From 2010-08-23 16:54:25 PST -------
(From update of attachment 65184 [details])
Is there a regression test covering this already?
------- Comment #5 From 2010-08-23 17:05:39 PST -------
Committed r65847
------- Comment #6 From 2010-08-23 17:40:37 PST -------
(In reply to comment #4)
> (From update of attachment 65184 [details] [details])
> Is there a regression test covering this already?

Yes, except we don't have any buildbots running tests with the JSC Interpreter:

fast/js/dictionary-no-cache.html
fast/js/pic/cached-prototype-setter.html
------- Comment #7 From 2010-08-24 10:08:04 PST -------
The regression was introduced in r62896 for Bug 41929.
<http://trac.webkit.org/changeset/62896>