Bug 44071 - SVG filters do not work on foreignObject
: SVG filters do not work on foreignObject
Status: RESOLVED DUPLICATE of bug 68251
Product: WebKit
Classification: Unclassified
Component: SVG
: 528+ (Nightly build)
: PC OS X 10.5
: P2 Normal
Assigned To: Nobody
: InRadar
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 13:58 PDT by Erik Arvidsson
Modified: 2012-01-30 14:26 PST (History)
7 users (show)

See Also:


Attachments
Simple test case (448 bytes, text/html)
2010-08-16 13:58 PDT, Erik Arvidsson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Arvidsson 2010-08-16 13:58:43 PDT
Created attachment 64517 [details]
Simple test case

It would be extremely useful if SVG filters could work on <foreignObject/>.

The attached file works in Firefox and it applies an SVG gaussian blur to a foreignObject containing some HTML.
Comment 1 Radar WebKit Bug Importer 2011-12-15 11:59:23 PST
<rdar://problem/10588373>
Comment 2 Philip Rogers 2012-01-30 08:34:21 PST
I believe this has been fixed in Chrome 17b and WebKit trunk, as the testcase works properly.
Comment 3 Nikolas Zimmermann 2012-01-30 12:31:32 PST
(In reply to comment #2)
> I believe this has been fixed in Chrome 17b and WebKit trunk, as the testcase works properly.
Reopening, the testcase should at least be commited first. Philip, can you prepare a patch for this?
Comment 4 Philip Rogers 2012-01-30 14:22:26 PST
I went to put together a patch but I think one already exists that covers this exact testcase: https://bugs.webkit.org/show_bug.cgi?id=68251 (specifically, LayoutTests/svg/foreginObject/fitler.html).

I'd love to get another easy patch :) but I think this bug should be marked as a duplicate of 68251 instead. What do you think?
Comment 5 Philip Rogers 2012-01-30 14:24:48 PST
(In reply to comment #4)
> I went to put together a patch but I think one already exists that covers this exact testcase: https://bugs.webkit.org/show_bug.cgi?id=68251 (specifically, LayoutTests/svg/foreginObject/fitler.html).
> 
> I'd love to get another easy patch :) but I think this bug should be marked as a duplicate of 68251 instead. What do you think?

Edit for misspelling: the correct existing test is LayoutTests/svg/foreignObject/filter.html.
Comment 6 Erik Arvidsson 2012-01-30 14:26:15 PST
68251 has tests that cover this.

*** This bug has been marked as a duplicate of bug 68251 ***