Bug 44059 - [Qt] fast/dom/Geolocation/disconnected-frame-permission-denied.html fails
Summary: [Qt] fast/dom/Geolocation/disconnected-frame-permission-denied.html fails
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2010-08-16 09:05 PDT by Csaba Osztrogonác
Modified: 2010-08-17 10:14 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.79 KB, patch)
2010-08-16 09:55 PDT, Steve Block
no flags Details | Formatted Diff | Diff
Patch (4.68 KB, patch)
2010-08-17 04:17 PDT, Steve Block
no flags Details | Formatted Diff | Diff
Patch (4.88 KB, patch)
2010-08-17 06:18 PDT, Steve Block
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2010-08-16 09:05:03 PDT
fast/dom/Geolocation/disconnected-frame-permission-denied.html introduced in 
http://trac.webkit.org/changeset/65416 and fails on Qt from the beginning:
http://build.webkit.org/results/Qt%20Linux%20Release/r65428%20%2817817%29/fast/dom/Geolocation/disconnected-frame-permission-denied-pretty-diff.html
Comment 1 Csaba Osztrogonác 2010-08-16 09:10:59 PDT
sorry for spamming, it isn't my day. :(
Comment 2 Steve Block 2010-08-16 09:20:57 PDT
This is also failing for Chromium. It looks like there's some flakiness in the test itself. Will disable the test while I investigate a fix.
Comment 3 Csaba Osztrogonác 2010-08-16 09:22:00 PDT
Skipped until fix: http://trac.webkit.org/changeset/65431
Comment 4 Steve Block 2010-08-16 09:42:44 PDT
Skipped for Chromium in http://trac.webkit.org/changeset/65436
Comment 5 Steve Block 2010-08-16 09:55:33 PDT
Created attachment 64501 [details]
Patch
Comment 6 Steve Block 2010-08-16 09:56:52 PDT
Hans, would it be possible for you to try my patch on Chromium?
Comment 7 Steve Block 2010-08-16 12:13:44 PDT
Comment on attachment 64501 [details]
Patch

Needs further investigation
Comment 8 Steve Block 2010-08-17 04:17:24 PDT
Created attachment 64572 [details]
Patch
Comment 9 Steve Block 2010-08-17 04:18:25 PDT
Hans has confirmed that this change fixes the test for Chromium. Csaba, would you be able to test on Qt please?
Comment 10 Csaba Osztrogonác 2010-08-17 06:13:29 PDT
(In reply to comment #9)
> Hans has confirmed that this change fixes the test for Chromium. Csaba, would you be able to test on Qt please?

Done. With this patch it works on Qt.
Comment 11 Steve Block 2010-08-17 06:18:55 PDT
Created attachment 64582 [details]
Patch
Comment 12 Steve Block 2010-08-17 06:20:09 PDT
> Done. With this patch it works on Qt.
Thanks.

I've uploaded a rebased patch.
Comment 13 Jeremy Orlow 2010-08-17 07:50:00 PDT
Comment on attachment 64582 [details]
Patch

LayoutTests/fast/dom/Geolocation/script-tests/disconnected-frame-permission-denied.js:14
 +      iframeGeolocation.getCurrentPosition(function() {
might be more clear to not have the functions be inline...

LayoutTests/fast/dom/Geolocation/script-tests/disconnected-frame-permission-denied.js:18
 +          error = e;
I would have done window.error

r=me
Comment 14 Steve Block 2010-08-17 08:30:07 PDT
Comment on attachment 64582 [details]
Patch

Submitting this as-is, as it follows the pattern used by the other Geolocation tests.
Comment 15 WebKit Commit Bot 2010-08-17 10:14:25 PDT
Comment on attachment 64582 [details]
Patch

Clearing flags on attachment: 64582

Committed r65513: <http://trac.webkit.org/changeset/65513>
Comment 16 WebKit Commit Bot 2010-08-17 10:14:31 PDT
All reviewed patches have been landed.  Closing bug.