Patch to follow.
Created attachment 64264 [details] [PATCH] Proposed change.
Comment on attachment 64264 [details] [PATCH] Proposed change. WebCore/inspector/front-end/InjectedScript.js:393 + InjectedScript.RemoteObjectId.deriveProperty = function(objectId, propertyName) Why not make it an instance method on RemoteObjectId? The code would be more compact. WebCore/inspector/front-end/inspector.js:1467 + WebInspector.console.addMessage(new WebInspector.ConsoleMessage( It will fail if it's called before WebInspector.console is initialized, please revert this code.
(In reply to comment #2) > (From update of attachment 64264 [details]) > WebCore/inspector/front-end/InjectedScript.js:393 > + InjectedScript.RemoteObjectId.deriveProperty = function(objectId, propertyName) > Why not make it an instance method on RemoteObjectId? The code would be more compact. > I'd like to emphasize the fact that the RemoteObjectId is payload here. Will rename it later when extracting the common part from both sides. > WebCore/inspector/front-end/inspector.js:1467 > + WebInspector.console.addMessage(new WebInspector.ConsoleMessage( > It will fail if it's called before WebInspector.console is initialized, please revert this code. Done, thanks.
Created attachment 64304 [details] [PATCH] Proposed fix.
Comment on attachment 64304 [details] [PATCH] Proposed fix. WebCore/inspector/front-end/inspector.js:1471 + function isLogAvailable() Please remove this
Committing to http://svn.webkit.org/repository/webkit/trunk ... M WebCore/ChangeLog M WebCore/inspector/front-end/ConsoleView.js M WebCore/inspector/front-end/InjectedScript.js M WebCore/inspector/front-end/PropertiesSidebarPane.js M WebCore/inspector/front-end/RemoteObject.js M WebCore/inspector/front-end/inspector.js Committed r65300 Committing to http://svn.webkit.org/repository/webkit/trunk ... M WebCore/ChangeLog M WebCore/inspector/front-end/inspector.js Committed r65301