Bug 43912 - [Chromium] Win/Linux SVG regressions from r65229
Summary: [Chromium] Win/Linux SVG regressions from r65229
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-12 06:09 PDT by Nate Chapin
Modified: 2013-04-09 16:27 PDT (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Chapin 2010-08-12 06:09:40 PDT
svg/W3C-SVG-1.1/masking-intro-01-f.svg = IMAGE
  svg/W3C-SVG-1.1/masking-mask-01-b.svg = IMAGE
  svg/batik/masking/maskRegions.svg = IMAGE
  svg/css/circle-in-mask-with-shadow.svg = IMAGE
  svg/css/mask-with-shadow.svg = IMAGE
  svg/custom/grayscale-gradient-mask.svg = IMAGE
  svg/custom/js-late-mask-and-object-creation.svg = IMAGE
  svg/custom/js-late-mask-creation.svg = IMAGE
  svg/custom/mask-child-changes.svg = IMAGE
  svg/custom/mask-colorspace.svg = IMAGE
  svg/custom/mask-on-multiple-objects.svg = IMAGE
  svg/custom/mask-with-all-units.svg = IMAGE
  svg/custom/mask-with-default-value.svg = IMAGE
  svg/zoom/page/zoom-mask-with-percentages.svg = IMAGE
Comment 1 Nate Chapin 2010-08-12 06:28:24 PDT
Chromium Win is failing the same set of tests too.
Comment 2 Nikolas Zimmermann 2010-08-12 06:52:16 PDT
Interessting, did the colorspace change? What happend?
Comment 4 Yuta Kitamura 2010-08-16 20:16:45 PDT
Following three tests started to fail on all three platforms:

  svg/W3C-SVG-1.1/filters-color-01-b.svg = IMAGE
  svg/W3C-SVG-1.1/filters-composite-02-b.svg = IMAGE
  svg/W3C-SVG-1.1/filters-offset-01-b.svg = IMAGE

Looks like the same issue.
Comment 5 Andrew Wilson 2010-10-01 14:22:29 PDT
This is now crashing sporadically on the chromium linux buildbots. Here's the output:


ASSERTION FAILED: !needsLayout()
(third_party/WebKit/WebCore/page/FrameView.cpp:1971 virtual void WebCore::FrameView::paintContents(WebCore::GraphicsContext*, const WebCore::IntRect&))
[32042:32042:13138200004393:ERROR:base/process_util_posix.cc(105)] Received signal 11
]
	StackTrace::StackTrace() [0x81a4536]
	base::(anonymous namespace)::StackDumpSignalHandler() [0x816255e]
	0x4001c420
	WebCore::ScrollView::paint() [0x88b1ce6]
	WebKit::WebFrameImpl::paintWithContext() [0x84ece9f]
	WebKit::WebFrameImpl::paint() [0x84ecf73]
	WebKit::WebViewImpl::paint() [0x851f2e0]
	WebWidgetHost::PaintRect() [0x8063097]
	WebWidgetHost::Paint() [0x806369d]
	TestShell::Dump() [0x804c0e9]
	TestShell::TestFinished() [0x80533ac]
	LayoutTestController::WorkQueue::ProcessWorkSoon() [0x8077ef8]
	LayoutTestController::LocationChangeDone() [0x8077f52]
	TestWebViewDelegate::LocationChangeDone() [0x8057f6e]
	TestWebViewDelegate::didFinishLoad() [0x8058de7]
	WebKit::FrameLoaderClientImpl::dispatchDidFinishLoad() [0x8540c87]
	WebCore::FrameLoader::checkLoadCompleteForThisFrame() [0x8bbdce8]
	WebCore::FrameLoader::recursiveCheckLoadComplete() [0x8bbde55]
	WebCore::FrameLoader::checkLoadComplete() [0x8bbdef7]
	WebCore::FrameLoader::finishedLoading() [0x8bbe061]
	WebCore::MainResourceLoader::didFinishLoading() [0x8bcce6c]
	WebCore::ResourceLoader::didFinishLoading() [0x8bd5f7b]
	WebCore::ResourceHandleInternal::didFinishLoading() [0x938ca78]
	webkit_glue::WebURLLoaderImpl::Context::OnCompletedRequest() [0x8fb1b97]
	(anonymous namespace)::RequestProxy::NotifyCompletedRequest() [0x8fdbeb9]
	DispatchToMethod<>() [0x8fdc353]
	RunnableMethod<>::Run() [0x8fdc38e]
	MessageLoop::RunTask() [0x81528b5]
	MessageLoop::DeferOrRunPendingTask() [0x8152961]
	MessageLoop::DoWork() [0x8152bf1]
	base::MessagePumpForUI::RunWithDispatcher() [0x81921fd]
	base::MessagePumpForUI::Run() [0x8192aff]
	MessageLoop::RunInternal() [0x8153423]
	MessageLoop::RunHandler() [0x815343d]
	MessageLoop::Run() [0x81534e1]
	TestShell::WaitTestFinished() [0x8052ea1]
	TestShell::RunFileTest() [0x80531df]
	main [0x8049b35]
	0x40bce450
	0x80481a1

flakiness dashboard:

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#tests=svg%2FW3C-SVG-1.1%2Fmasking-intro-01-f.svg
Comment 6 Adam Klein 2012-02-29 13:58:43 PST
svg/custom/grayscale-gradient-mask.svg no longer seems to be failing, removing suppression.
Comment 7 Stephen Chenney 2013-04-09 16:27:55 PDT
Marking test failures as WontFix. Bug is still accessible and recording in TestExpectations.