Bug 43842 - Refactoring the fpu code generator for the ARM port
Summary: Refactoring the fpu code generator for the ARM port
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-11 03:44 PDT by Zoltan Herczeg
Modified: 2010-08-13 00:53 PDT (History)
3 users (show)

See Also:


Attachments
patch (13.14 KB, patch)
2010-08-11 03:56 PDT, Zoltan Herczeg
no flags Details | Formatted Diff | Diff
patch 2 (13.14 KB, patch)
2010-08-12 01:06 PDT, Zoltan Herczeg
barraclough: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Herczeg 2010-08-11 03:44:36 PDT
We should support the new fpu features and instruction mnemonics!
Comment 1 Zoltan Herczeg 2010-08-11 03:56:48 PDT
Created attachment 64091 [details]
patch
Comment 2 WebKit Review Bot 2010-08-11 03:58:16 PDT
Attachment 64091 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
JavaScriptCore/assembler/ARMAssembler.h:443:  vadd_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:448:  vdiv_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:453:  vsub_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:458:  vmul_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:463:  vcmp_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:468:  vsqrt_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:557:  vmov_vfp_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:563:  vmov_arm_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:569:  vcvt_f64_s32_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:575:  vcvt_s32_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:581:  vmrs_apsr is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 11 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Zoltan Herczeg 2010-08-11 04:00:57 PDT
The _r postfix is not used anymore, we should remove it as well.
Comment 4 Gabor Loki 2010-08-11 04:01:25 PDT
(In reply to comment #0)
> We should support the new fpu features and instruction mnemonics!

It is more like a style change than a functional one.
Comment 5 Zoltan Herczeg 2010-08-12 01:06:27 PDT
Created attachment 64190 [details]
patch 2

Little renaming: vd vn vm -> dd dn dm
Comment 6 WebKit Review Bot 2010-08-12 01:07:44 PDT
Attachment 64190 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
JavaScriptCore/assembler/ARMAssembler.h:443:  vadd_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:448:  vdiv_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:453:  vsub_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:458:  vmul_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:463:  vcmp_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:468:  vsqrt_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:557:  vmov_vfp_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:563:  vmov_arm_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:569:  vcvt_f64_s32_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:575:  vcvt_s32_f64_r is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMAssembler.h:581:  vmrs_apsr is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 11 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Zoltan Herczeg 2010-08-13 00:53:29 PDT
Landed in http://trac.webkit.org/changeset/65303
Closing bug