Bug 43801 - [QT] QtTestBrowser freezes when loading the desktop version of www.yahoo.com
Summary: [QT] QtTestBrowser freezes when loading the desktop version of www.yahoo.com
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: S60 Hardware S60 3rd edition
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-08-10 11:34 PDT by Alexandra Santos
Modified: 2010-11-02 12:37 PDT (History)
2 users (show)

See Also:


Attachments
call stack (2.70 MB, image/bmp)
2010-11-02 08:40 PDT, qi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandra Santos 2010-08-10 11:34:50 PDT
Steps to reproduce:

1.- Install QtWebkit 2.1 on a symbian device (symbian 4)
2.- Install and Launch QtTestBrowser.
3.- Load www.yahoo.com
4.- Click on the "Desktop" link at the bottom of this page.

Actual Results:

QtTest browser freezes while loading the page.

Expected results:

QtTestBrowser would load the page just fine.
Comment 1 Simon Hausmann 2010-08-19 11:14:00 PDT

*** This bug has been marked as a duplicate of bug 43824 ***
Comment 2 Suresh Voruganti 2010-10-20 12:18:08 PDT
Re opening the error as the title issue is still reproducible, as the duplicated bug  43824 is not reproducible .
Comment 3 Suresh Voruganti 2010-10-26 11:32:01 PDT
Adding dependency to 39121 as this is Basic Acceptance test failure for Qtwebkit 2.1 and issue need to be fixed.
Comment 4 qi 2010-11-02 08:40:07 PDT
Created attachment 72672 [details]
call stack 

Attached the call stack on Carbide.

I doubt the "lrudata" is a garbage in this case. 
I try to increase the callstack number, it doesn't help.

I think it is QVGImagePool issue.
Comment 5 Alexandra Santos 2010-11-02 12:35:45 PDT
This issue is not reproducible on symbian when using the QVGImagePool patch.
Comment 6 Suresh Voruganti 2010-11-02 12:37:42 PDT
Resolving the error as Invalid as this Qt issue.