Allow an assembler/macroassembler to compact branches to more concise forms when linking
Created attachment 63964 [details] Patch
Attachment 63964 [details] did not pass style-queue: Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1 JavaScriptCore/assembler/ARMv7Assembler.h:2032: JUMP_TEMPORARY_REGISTER is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 1 in 20 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 63964 [details] Patch > void breakpoint(uint8_t imm = 0) The macroassembler interface should be identical for all platforms. (Hmmm, we should probably have a better way of enforcing this; maybe we should make MacroAssembler privately inherit from MacroAssemblerBase & add wrapper methods to enforce a single API). If breakpoint is going to take a uint8_t it really has to do so on all platforms, but since this might be difficult to usefully implement on other architectures I think a better solution would be to revert this change at this level (still add to ARMv7Assembler). That way you can still use m_assembler.bkpt(N); when debugging on ARMv7. Please remove teh thousands of ", 0"s, restore default argy goodness.
Committed r65042: <http://trac.webkit.org/changeset/65042>