Bug 43664 - Scripts on local filesystem injected after window.onload are never reloaded
Summary: Scripts on local filesystem injected after window.onload are never reloaded
Status: RESOLVED DUPLICATE of bug 30862
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-06 20:23 PDT by Ryan Grove
Modified: 2010-08-07 01:33 PDT (History)
2 users (show)

See Also:


Attachments
Reduced test case that reproduces the bug (710 bytes, application/zip)
2010-08-06 20:23 PDT, Ryan Grove
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Grove 2010-08-06 20:23:31 PDT
Created attachment 63799 [details]
Reduced test case that reproduces the bug

A script on the local filesystem (i.e., a file:// URL) that's loaded via a script node added after the window.onload event has fired will never be reloaded until the cache is manually cleared. In Google Chrome (which also exhibits this bug), even manually clearing the cache is ineffective.

When the same script is injected before the window.onload event has fired, it behaves as expected and is reloaded normally whenever the page is refreshed.

To reproduce:

1. Download the attached test.zip file and extract it.
2. Open the extracted test.html file from your local filesystem. You should see the string "foo" in bold at the bottom of the page.
3. Edit test.js and change the value of the string to "bar".
4. Reload the page. You'll still see "foo".
5. (If using Google Chrome) Clear your cache. Reload. Still "foo".
Comment 1 Alexey Proskuryakov 2010-08-07 00:49:35 PDT

*** This bug has been marked as a duplicate of bug 30862 ***