Bug 43494 - mac-wk2/Skipped should be used on Windows when running regression tests
Summary: mac-wk2/Skipped should be used on Windows when running regression tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Jon Honeycutt
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-08-04 10:59 PDT by Adam Roben (:aroben)
Modified: 2010-08-10 23:10 PDT (History)
6 users (show)

See Also:


Attachments
Patch (111.18 KB, patch)
2010-08-06 04:08 PDT, Jon Honeycutt
aroben: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2010-08-04 10:59:40 PDT
Nearly all of the failures in mac-wk2/Skipped are due to cross-platform issues. We should make Windows use this file, too, rather than having to maintain an entirely separate Skipped file for Windows. win-wk2/Skipped should be concatenated with the Mac file so that Windows-specific failures can be listed. (Note that this will make it impossible to run tests on Windows that aren't run on Mac, but that's probably worth the easier maintenance.)
Comment 1 Adam Roben (:aroben) 2010-08-04 11:00:13 PDT
<rdar://problem/8272368>
Comment 2 Jon Honeycutt 2010-08-06 04:08:39 PDT
Created attachment 63710 [details]
Patch
Comment 3 Adam Roben (:aroben) 2010-08-06 07:00:05 PDT
Comment on attachment 63710 [details]
Patch

> -    foreach my $level (@platformTestHierarchy) {
> +    my @skippedFilePaths = @platformTestHierarchy;

I'd call this @skippedFileDirectories, since it contains paths to directories that contain Skipped files, rather than paths to Skipped files themselves.

> +    # Because nearly all of the skipped tests for WebKit 2 on Mac are due to
> +    # cross-platform issues, Windows will use both the Mac and Windows skipped
> +    # lists to avoid maintaining separate lists.
> +    if ($platform eq "win-wk2") {
> +        push(@skippedFilePaths, catdir($platformBaseDirectory, "mac-wk2"));
> +    }

For a single-line branch like this it's often nicer to write it using this syntax:

push(@skippedFilePaths, catdir($platformBaseDirectory, "mac-wk2")) if $platform eq "win-wk2";

r=me
Comment 4 WebKit Review Bot 2010-08-06 16:03:58 PDT
http://trac.webkit.org/changeset/64876 might have broken Qt Linux Release
Comment 5 Adam Barth 2010-08-10 23:10:51 PDT
This patch appears to have been landed.