Created attachment 63376 [details]
This patch seems sane to me. Perhaps adding a WEBKITGTK_API_VERSION define and setting it to @WEBKITGTK_API_VERSION@ would make this bit of code future proof though. Then the path could just be:
Comment on attachment 63376 [details]
Martin is right, we should do as he says. I'll upload a patch doing that tomorrow.
The patch suggested by Martin was committed as r64752, closing.