Bug 43388 - SVGPathElement.cloneNode loses generated pathSegList
Summary: SVGPathElement.cloneNode loses generated pathSegList
Status: RESOLVED DUPLICATE of bug 49580
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on: 10827
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 16:21 PDT by Nathan Vander Wilt
Modified: 2010-11-17 06:39 PST (History)
3 users (show)

See Also:


Attachments
Test case, should show two identical paths next to each other (1.68 KB, text/html)
2010-08-02 16:21 PDT, Nathan Vander Wilt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Vander Wilt 2010-08-02 16:21:00 PDT
Created attachment 63273 [details]
Test case, should show two identical paths next to each other

If an SVG path is created programmatically via its DOM pathSegList's methods, duplicate path elements created with .cloneNode() have an empty pathSegList. This may be related to https://bugs.webkit.org/show_bug.cgi?id=41421 but is not fixed by its patch.
Comment 1 Nikolas Zimmermann 2010-11-17 06:39:22 PST

*** This bug has been marked as a duplicate of bug 49580 ***