We have quite a few feature defines for blob related features, like ENABLE(BLOB_SLICE) and ENABLE(FILE_READER). We do not want another feature define when we start to support blob URL. Thus it would be better if we could unify all blob related defines to one simple define. So we need to change ENABLE(BLOB_SLICE) and ENABLE(FILE_READER) to ENABLE(BLOB). The future work of blob URL is also going to put under ENABLE(BLOB). Note that ENABLE(FILE_WRITER) remains unchanged since it is also related to file system work and thus it needs additional guard.
Created attachment 62779 [details]
Comment on attachment 62779 [details]
r- due to removal of if's in BlobItem.* as discussed.
Created attachment 62780 [details]
http://trac.webkit.org/changeset/64763 might have broken Qt Linux Release
Committed as http://trac.webkit.org/changeset/64763.