Bug 43068 - Move NPJSObject out into separate files
Summary: Move NPJSObject out into separate files
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-27 12:22 PDT by Anders Carlsson
Modified: 2010-07-27 12:30 PDT (History)
1 user (show)

See Also:


Attachments
Patch (19.96 KB, patch)
2010-07-27 12:25 PDT, Anders Carlsson
aroben: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-07-27 12:22:26 PDT
Move NPJSObject out into separate files
Comment 1 Anders Carlsson 2010-07-27 12:25:51 PDT
Created attachment 62725 [details]
Patch
Comment 2 Adam Roben (:aroben) 2010-07-27 12:28:09 PDT
Comment on attachment 62725 [details]
Patch

r=me
Comment 3 WebKit Review Bot 2010-07-27 12:28:40 PDT
Attachment 62725 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/NPJSObject.cpp:26:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:129:  NPJSObject::NP_Allocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:136:  NPJSObject::NP_Deallocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:142:  NPJSObject::NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.cpp:147:  NPJSObject::NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPRuntimeObjectMap.h:34:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:34:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:66:  NP_Allocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:67:  NP_Deallocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:68:  NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObject.h:69:  NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 11 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Anders Carlsson 2010-07-27 12:30:33 PDT
Committed r64147: <http://trac.webkit.org/changeset/64147>