Bug 42975 - Browser failing HTML 5.0 Selectors API tests
Summary: Browser failing HTML 5.0 Selectors API tests
Status: RESOLVED DUPLICATE of bug 42968
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: S60 Hardware S60 3rd edition
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-26 08:50 PDT by nokiabugz
Modified: 2010-07-28 16:08 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nokiabugz 2010-07-26 08:50:34 PDT
To Reproduce:

Load http://ejohn.org/apps/selectortest
Tests run automatically. Results:

99.3%: 2148 passed, 16 failed
FAIL Element.querySelectorAll no value
FAIL Element.querySelector no value
FAIL Syntax Error: Element.querySelectorAll no value
FAIL Syntax Error: Element.querySelector no value
FAIL Disconnected Element.querySelectorAll no value
FAIL Disconnected Element.querySelector no value
FAIL Syntax Error: Disconnected Element.querySelectorAll no value
FAIL Syntax Error: Disconnected Element.querySelector no value
FAIL Fragment.querySelectorAll no value
FAIL Fragment.querySelector no value
FAIL Syntax Error: Fragment.querySelectorAll no value
FAIL Syntax Error: Fragment.querySelector no value
FAIL Document.querySelectorAll no value
FAIL Document.querySelector no value
FAIL Syntax Error: Document.querySelectorAll no value
FAIL Syntax Error: Document.querySelector no value

This issue can be reproduced using the Chrome, Safari and Firefox desktop browsers (identical results).
Comment 1 Jakub Wieczorek 2010-07-28 16:08:54 PDT

*** This bug has been marked as a duplicate of bug 42968 ***