Break out "scheme registration" functionality to a SchemeRegistry.
Currently, SecurityOrigin tracks "stuff" about Schemes that can be programmatically registered. Some of the associations to SecurityOrigin were already kind of loose.
To support future WebKit API we'd like to track other special types of schemes that are in no way related to SecurityOrigin.
We can model MIMETypeRegistry here, as a central holding tank for all Schemes WebCore/WebKit already know about, as well as giving client apps a way to customize things a bit.
Created attachment 62229 [details]
Comment on attachment 62229 [details]
Boo on two names for the same thing. I would rename "localSchemes" to "localURLSchemes". (Requires a namespace qualification on the return statement.)
Seems like these fast cases should assert that they're correct. Something like "ASSERT(localSchemes().contains(X))".
Committed r63863: <http://trac.webkit.org/changeset/63863>