Bug 42526 - More NPRuntime work
Summary: More NPRuntime work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-18 15:16 PDT by Anders Carlsson
Modified: 2010-07-18 15:27 PDT (History)
1 user (show)

See Also:


Attachments
Patch (8.12 KB, patch)
2010-07-18 15:19 PDT, Anders Carlsson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-07-18 15:16:41 PDT
More NPRuntime work
Comment 1 Anders Carlsson 2010-07-18 15:19:09 PDT
Created attachment 61914 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-18 15:21:14 PDT
Attachment 61914 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:313:  NPN_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapeBrowserFuncs.cpp:336:  NPN_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:75:  NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:76:  NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:174:  NPJSObject::NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/NPJSObjectMap.cpp:179:  NPJSObject::NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 6 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Sam Weinig 2010-07-18 15:22:39 PDT
Comment on attachment 61914 [details]
Patch

> +    static bool NP_HasProperty(NPObject *npobj, NPIdentifier name);
> +    static bool NP_GetProperty(NPObject *npobj, NPIdentifier name, NPVariant *result);

* on the wrong side.

> +
> +    const char *string = identifierRep->string();

* on the wrong side.

Otherwise, r=me.
Comment 4 Anders Carlsson 2010-07-18 15:27:50 PDT
Committed r63636: <http://trac.webkit.org/changeset/63636>