Add dumping of statusbar text to WebKitTestRunner
Created attachment 61902 [details] Patch
Attachment 61902 [details] did not pass style-queue: Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1 WebKit2/WebProcess/InjectedBundle/API/c/WKBundlePage.h:70: Extra space between WKBundlePageSetStatusbarTextCallback and setStatusbarText [whitespace/declaration] [3] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.h:64: _setStatusbarText is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundlePage.cpp:202: InjectedBundlePage::_setStatusbarText is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 3 in 10 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 61902 [details] Patch > typedef void (*WKBundlePageAddMessageToConsoleCallback)(WKBundlePageRef page, WKStringRef message, uint32_t lineNumber, const void *clientInfo); Star on the wrong side of the space here. > +typedef void (*WKBundlePageSetStatusbarTextCallback)(WKBundlePageRef page, WKStringRef statusbarText, const void *clientInfo); and here > const void * clientInfo; and here > +void InjectedBundlePage::_setStatusbarText(WKBundlePageRef page, WKStringRef statusbarText, const void *clientInfo) and here > static void _addMessageToConsole(WKBundlePageRef page, WKStringRef message, uint32_t lineNumber, const void *clientInfo); and here > + static void _setStatusbarText(WKBundlePageRef page, WKStringRef statusbarText, const void *clientInfo); and here r=me if you fix the style issues.
(In reply to comment #3) > (From update of attachment 61902 [details]) > > typedef void (*WKBundlePageAddMessageToConsoleCallback)(WKBundlePageRef page, WKStringRef message, uint32_t lineNumber, const void *clientInfo); > > Star on the wrong side of the space here. I was wrong. CF-style is that the space comes before the star. r=me then.
Committed r63627: <http://trac.webkit.org/changeset/63627>