Bug 42384 - Send JavaScript stream data to plug-ins
Summary: Send JavaScript stream data to plug-ins
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-15 09:39 PDT by Anders Carlsson
Modified: 2010-07-15 11:19 PDT (History)
2 users (show)

See Also:


Attachments
Patch (9.22 KB, patch)
2010-07-15 09:44 PDT, Anders Carlsson
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-07-15 09:39:03 PDT
Send JavaScript stream data to plug-ins
Comment 1 Anders Carlsson 2010-07-15 09:44:06 PDT
Created attachment 61675 [details]
Patch
Comment 2 WebKit Review Bot 2010-07-15 09:49:46 PDT
Attachment 61675 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:65:  NPP_WriteReady is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.h:66:  NPP_Write is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:161:  NetscapePlugin::NPP_WriteReady is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/Plugins/Netscape/NetscapePlugin.cpp:166:  NetscapePlugin::NPP_Write is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 4 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Darin Adler 2010-07-15 09:51:45 PDT
Comment on attachment 61675 [details]
Patch

> +void NetscapePluginStream::deliverData(const char* bytes, int length)

int? int32_t? unsigned? uint32_t? size_t? Our seemingly random length types drive me crazy!

Does this already have layout test coverage?

r=me
Comment 4 Anders Carlsson 2010-07-15 10:13:54 PDT
(In reply to comment #3)
> (From update of attachment 61675 [details])
> > +void NetscapePluginStream::deliverData(const char* bytes, int length)
> 
> int? int32_t? unsigned? uint32_t? size_t? Our seemingly random length types drive me crazy!
> 

Yeah it's really annoying. I used the same type as ResourceHandleClient::didReceiveData. We should definitly fix didReceiveData and all the clients etc to use a size_t instead.

> Does this already have layout test coverage?

Yes.
Comment 5 Anders Carlsson 2010-07-15 11:19:53 PDT
Committed r63439: <http://trac.webkit.org/changeset/63439>