Bug 42323 - WebKitTestRunner needs to support layoutTestController.keepWebHistory
Summary: WebKitTestRunner needs to support layoutTestController.keepWebHistory
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-07-14 20:49 PDT by Maciej Stachowiak
Modified: 2010-07-25 23:04 PDT (History)
2 users (show)

See Also:


Attachments
Patch (46.46 KB, patch)
2010-07-25 22:47 PDT, Darin Adler
mjs: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2010-07-14 20:49:56 PDT
WebKitTestRunner needs to support layoutTestController.keepWebHistory
Comment 1 Maciej Stachowiak 2010-07-14 20:58:14 PDT
<rdar://problem/8193632>
Comment 2 Darin Adler 2010-07-25 22:47:39 PDT
Created attachment 62543 [details]
Patch
Comment 3 WebKit Review Bot 2010-07-25 22:49:17 PDT
Attachment 62543 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundle.h:63:  _didReceiveMessage is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKitTools/WebKitTestRunner/TestController.h:70:  _didReceiveMessageFromInjectedBundle is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/WebProcess/InjectedBundle/API/c/WKBundle.h:46:  Extra space between WKBundleDidReceiveMessageCallback and didReceiveMessage  [whitespace/declaration] [3]
WebKit2/UIProcess/API/C/WKContext.h:41:  Extra space between WKContextDidReceiveMessageFromInjectedBundleCallback and didReceiveMessageFromInjectedBundle  [whitespace/declaration] [3]
WebKitTools/WebKitTestRunner/TestController.cpp:129:  TestController::_didReceiveMessageFromInjectedBundle is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKitTools/WebKitTestRunner/InjectedBundle/InjectedBundle.cpp:60:  InjectedBundle::_didReceiveMessage is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 6 in 30 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Maciej Stachowiak 2010-07-25 22:56:02 PDT
Comment on attachment 62543 [details]
Patch

WebKitTools/WebKitTestRunner/InjectedBundle/LayoutTestController.cpp:114
 +      // FIXME: Is it OK this works only for the main frmae?
Typo: frmae. Repeated in several places.


r=me
Comment 5 Darin Adler 2010-07-25 23:04:03 PDT
Committed r64029: <http://trac.webkit.org/changeset/64029>