Bug 4227 - The ex unit doesn't work for font-variant: small-caps
Summary: The ex unit doesn't work for font-variant: small-caps
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2005-07-30 15:45 PDT by James Sumners
Modified: 2006-02-19 09:44 PST (History)
2 users (show)

See Also:


Attachments
Testcase (183 bytes, text/html)
2005-12-29 06:42 PST, Joost de Valk (AlthA)
no flags Details
Add font-variant to the list of properties applied first (4.96 KB, patch)
2006-02-17 04:28 PST, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Sumners 2005-07-30 15:45:19 PDT
p#test { font-variant: small-caps; letter-spacing: 0.2ex; } will produce a paragraph element with the text 
rendered in small caps but with normal letter spacing.

p#test { letter-spacing: 0.2ex; font-variant: small-caps; } will produce a paragraph element with the text 
rendered in small caps and the letter spacing set to 0.2ex.
Comment 1 Joost de Valk (AlthA) 2005-12-29 06:41:36 PST
Confirmed, testcase coming up.
Comment 2 Joost de Valk (AlthA) 2005-12-29 06:42:20 PST
Created attachment 5351 [details]
Testcase
Comment 3 mitz 2006-02-17 01:27:03 PST
The problem seems to be only with the 'ex' unit. Specifying letter-spacing in other units works for small-caps. On the other hand, it is not limited to the letter-spacing property.
Comment 4 mitz 2006-02-17 04:28:42 PST
Created attachment 6562 [details]
Add font-variant to the list of properties applied first
Comment 5 Darin Adler 2006-02-17 07:51:06 PST
Comment on attachment 6562 [details]
Add font-variant to the list of properties applied first

r=me
Comment 6 Alexey Proskuryakov 2006-02-19 09:04:54 PST
The test from this patch doesn't pass for me - there is no green box, and an error is reported:
=================
ERROR: called xHeight on an empty QFontMetrics
(/Users/ap/WebKit/WebCore/kwq/KWQFontMetrics.mm:153 xHeight)
=================
Comment 7 Alexey Proskuryakov 2006-02-19 09:44:45 PST
Sorry, it was my mistake.