RESOLVED FIXED 42104
Web Inspector: next step of the Remote Debugger. Transition from InspectorFrontend2.idl to Inspector.idl
https://bugs.webkit.org/show_bug.cgi?id=42104
Summary Web Inspector: next step of the Remote Debugger. Transition from InspectorFro...
Ilya Tikhonovsky
Reported 2010-07-12 13:16:47 PDT
Next iteration of Inspector code generator. The InspectorFrontend2 was replaced by slightly modified version of InspectorBackend file (Inspector.idl). At the end all the interface between WebInspector and inspected page will be specified by this file and generated by CodeGeneratorInspector (InspectorFrontend.cpp, InspectorBackend.cpp and InspectorBackend.js). Initial version of InspectorFrontend2 had did* functions. Almost all these functions were the answers for corresponding functions from InspectorBackend. It is quite simple to generate these functions by processing InspectorBackend.idl. At the moment InspectorBackend is used for generate binding. As far as this interface specification will be used for generate both sides of Inspector API we should be able to mark some argument as 'out'.
Attachments
[patch] initial version. (45.98 KB, patch)
2010-07-12 13:18 PDT, Ilya Tikhonovsky
no flags
[patch] second iteration. With fixed gtk, windows and efl. (48.27 KB, patch)
2010-07-12 22:44 PDT, Ilya Tikhonovsky
no flags
[patch] third iteration. (47.94 KB, patch)
2010-07-13 00:38 PDT, Ilya Tikhonovsky
yurys: review+
Ilya Tikhonovsky
Comment 1 2010-07-12 13:18:16 PDT
Created attachment 61260 [details] [patch] initial version.
WebKit Review Bot
Comment 2 2010-07-12 17:33:47 PDT
Ilya Tikhonovsky
Comment 3 2010-07-12 22:44:55 PDT
Created attachment 61329 [details] [patch] second iteration. With fixed gtk, windows and efl.
Yury Semikhatsky
Comment 4 2010-07-12 23:34:00 PDT
Comment on attachment 61329 [details] [patch] second iteration. With fixed gtk, windows and efl. WebCore/inspector/Inspector.idl:125 + [skipSuccessFlag] void getStyles(in long nodeId, in boolean authOnly, out Value styles); [skipSuccessFlag] - can we use "out bool success" parameter instead? Or pass this flag to every method? WebCore/inspector/Inspector.idl:4 + * Copyright (C) 2009 Google Inc. All rights reserved. 2010 WebCore/inspector/CodeGeneratorInspector.pm:173 + my $argumentsFilter; argumentsFilter -> argumentsDirection? WebCore/inspector/CodeGeneratorInspector.pm:200 + my $pushCall = $typeTransform{$parameter->type}->{"push"}; Please rename "push" key to something more descriptive as we discussed offline.
Ilya Tikhonovsky
Comment 5 2010-07-13 00:38:56 PDT
Created attachment 61338 [details] [patch] third iteration. skipSuccessFlag - was removed; Copyright - was fixed; $argumentsFilter -> $argumentsDirectionFilter $pushCall -> $pushFunctionName
WebKit Review Bot
Comment 6 2010-07-13 01:04:19 PDT
Yury Semikhatsky
Comment 7 2010-07-13 02:02:04 PDT
Comment on attachment 61338 [details] [patch] third iteration. WebCore/inspector/Inspector.idl:4 + * Copyright (C) 2009, 20010 Google Inc. All rights reserved. 20010 ?
Ilya Tikhonovsky
Comment 8 2010-07-13 09:31:58 PDT
Committing to http://svn.webkit.org/repository/webkit/trunk ... D WebCore/inspector/InspectorFrontend2.idl M WebCore/CMakeLists.txt M WebCore/ChangeLog M WebCore/DerivedSources.make M WebCore/GNUmakefile.am M WebCore/WebCore.gyp/WebCore.gyp M WebCore/WebCore.gyp/scripts/rule_binding.py M WebCore/WebCore.gypi M WebCore/WebCore.pri M WebCore/WebCore.vcproj/WebCore.vcproj M WebCore/WebCore.xcodeproj/project.pbxproj M WebCore/bindings/scripts/IDLParser.pm M WebCore/bindings/scripts/IDLStructure.pm M WebCore/bindings/scripts/generate-bindings.pl M WebCore/inspector/CodeGeneratorInspector.pm A WebCore/inspector/Inspector.idl M WebCore/inspector/InspectorCSSStore.cpp M WebCore/inspector/InspectorController.cpp M WebCore/inspector/InspectorController.h M WebCore/inspector/InspectorDOMAgent.cpp M WebCore/inspector/InspectorDOMAgent.h M WebCore/inspector/InspectorTimelineAgent.cpp M WebCore/inspector/InspectorTimelineAgent.h M cmake/WebKitGenerators.cmake Committed r63198
Joseph Pecoraro
Comment 9 2010-07-13 10:38:40 PDT
Comment on attachment 61338 [details] [patch] third iteration. Hey! Some minor comments. > +++ b/WebCore/inspector/Inspector.idl > + [custorResponse=didApplyDomChange] void setAttribute(in long elementId, in String name, in String value, out boolean success); Typo: "custorResponse" should be "customResponse" ? > +#if defined(ENABLE_OFFLINE_WEB_APPLICATIONS) This is my fault from a while ago. It should be like the other checks: #if defined(ENABLE_OFFLINE_WEB_APPLICATIONS) && ENABLE_OFFLINE_WEB_APPLICATIONS
Note You need to log in before you can comment on or make changes to this bug.