Bug 42041 - Refactor the entity parser to handle new entities needed by MathML 3
Summary: Refactor the entity parser to handle new entities needed by MathML 3
Status: RESOLVED DUPLICATE of bug 43595
Alias: None
Product: WebKit
Classification: Unclassified
Component: MathML (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 3251
  Show dependency treegraph
 
Reported: 2010-07-11 01:08 PDT by François Sausset
Modified: 2010-08-05 20:39 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description François Sausset 2010-07-11 01:08:59 PDT
The w3c published a new recommendation for entity names: http://www.w3.org/TR/xml-entity-names/.
MathML 3 should implement all these entities and HTML 5 only a subset.
However, the actual entity parser cannot handle these new entities.

Thus, the entity parser should be rewritten in the following way (see discussion on the mailing list):
- use a prefix tree instead of a hash table (faster and handle entity names as long as wanted)
- handle entities associated to combined Unicode characters
- solve the conflict with XHTML 1.0 about ⟩ and ⟨ (see w3c webpage above)
Comment 1 Adam Barth 2010-08-05 20:39:59 PDT

*** This bug has been marked as a duplicate of bug 43595 ***