Bug 41934 - REGRESSION: SVG Font selection problems
Summary: REGRESSION: SVG Font selection problems
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.w3.org/Graphics/SVG/Test/2...
Keywords:
Depends on: 59085
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 23:22 PDT by Dirk Schulze
Modified: 2011-06-20 01:29 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Schulze 2010-07-08 23:22:31 PDT
It's not possible to select single chars on the text in the exmaple above. Double click just selects Gradient, it's not possible to select another word beside selecting the complete text with tripple click.

(Selecting of char's never worked correctly, but was possible in earlier versions)
Comment 1 Nikolas Zimmermann 2010-07-09 08:57:07 PDT
Known bug, this can't work at the moment, since we've switched to use offsetForPosition() in the SVG Text code, which is not implemented for SVGFonts. See SVGFont.cpp, TODO in the last function.
Comment 2 Emil Schutte 2011-01-28 18:48:11 PST
This should be fixed by the patch I submitted today for https://bugs.webkit.org/show_bug.cgi?id=36840 .
Comment 3 Nikolas Zimmermann 2011-06-20 01:29:35 PDT
Fixed in r89233.