Bug 41762 - [v8] Web Inspector: stack trace is broken when there are functions from internal scripts
Summary: [v8] Web Inspector: stack trace is broken when there are functions from inter...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yury Semikhatsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-07 05:47 PDT by Yury Semikhatsky
Modified: 2010-07-07 06:07 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.57 KB, patch)
2010-07-07 05:50 PDT, Yury Semikhatsky
no flags Details | Formatted Diff | Diff
Patch (1.96 KB, patch)
2010-07-07 05:53 PDT, Yury Semikhatsky
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2010-07-07 05:47:09 PDT
Web Inspector fails to show correct call stack when it contains functions from internal scripts(e.g. extensions are partially written in JavaScript). This happens because these scripts are precompiled and their sources are not available in runtime. Web Inspector fails to resolve script for first of them and skips all the rest. I think we should show the frames corresponding to those  functions in the call stack.

Steps to reproduce:
1. Install a Chromium extension with background page.
2. Set a breakpoint in the background page.
3. Execute code hitting the breakpoint.

Result:
Only top frame is shown and it's not selected.
Comment 1 Yury Semikhatsky 2010-07-07 05:50:57 PDT
Created attachment 60723 [details]
Patch
Comment 2 Yury Semikhatsky 2010-07-07 05:53:50 PDT
Created attachment 60725 [details]
Patch
Comment 3 Pavel Feldman 2010-07-07 05:56:31 PDT
Comment on attachment 60725 [details]
Patch

WebCore/inspector/front-end/CallStackSidebarPane.js:64
 +              if (scriptOrResource) {
remove {}
Comment 4 Yury Semikhatsky 2010-07-07 06:07:42 PDT
Committed r62658