RESOLVED FIXED 41608
DeviceOrientation should be renamed to DeviceOrientationController
https://bugs.webkit.org/show_bug.cgi?id=41608
Summary DeviceOrientation should be renamed to DeviceOrientationController
Steve Block
Reported 2010-07-05 05:15:35 PDT
This is consistent with other controllers, eg Geolocation, and will allow the name DeviceOrientation to be used to represent a set of device orientation data. This will be cleaner than passing around the 3 bools and 3 doubles required to represent the optional properties of the DeviceOrientationEvent.
Attachments
Patch (23.69 KB, patch)
2010-07-05 07:39 PDT, Steve Block
no flags
Patch (23.70 KB, patch)
2010-07-05 08:18 PDT, Steve Block
abarth: review+
Steve Block
Comment 1 2010-07-05 07:39:11 PDT
Hans Wennborg
Comment 2 2010-07-05 08:14:13 PDT
This sounds good to me. Only found one issue: In WebCore/page/Page.h: > - DeviceOrientation* deviceOrientation() const { return m_deviceOrientation.get(); } > + DeviceOrientationController* deviceOrientationController() const { return m_deviceOrientation.get(); } I guess this should return m_deviceOrientationController.get()?
Steve Block
Comment 3 2010-07-05 08:18:13 PDT
Adam Barth
Comment 4 2010-07-07 02:46:35 PDT
Comment on attachment 60539 [details] Patch WebCore/dom/DeviceOrientationController.h:38 + // FIXME: Add methods to start and stop the service. This patch will make more sense once we do this FIXME. It's not really controlling the DeviceOrientation, is it? That would be kind of awesome. Instead, it's controlling the DeviceOrientation service, right? I guess the GeolocationController isn't controlling the geolocation either. I guess brevity is a virtue here and DeviceOrientationServiceController is too long... Anyway, not 100% cheesed about the name.
Steve Block
Comment 5 2010-07-07 02:52:52 PDT
Note You need to log in before you can comment on or make changes to this bug.