Bug 41597 - Don't pass image hash to DRT when pixel tests are disabled
Summary: Don't pass image hash to DRT when pixel tests are disabled
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-05 02:46 PDT by Gabor Rapcsanyi
Modified: 2010-07-06 02:43 PDT (History)
6 users (show)

See Also:


Attachments
proposed patch (1.44 KB, patch)
2010-07-05 04:10 PDT, Gabor Rapcsanyi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Rapcsanyi 2010-07-05 02:46:48 PDT
new-run-webkit-tests shouldn't pass image hash to DRT when pixel tests are disabled.
Comment 1 Gabor Rapcsanyi 2010-07-05 04:10:31 PDT
Created attachment 60510 [details]
proposed patch
Comment 2 Eric Seidel (no email) 2010-07-06 02:05:24 PDT
Comment on attachment 60510 [details]
proposed patch

Does this match old-run-webkit-tests?  Why is Qt the only port which has noticed this? (Because other ports aren't using NRWT much yet?)
Comment 3 Gabor Rapcsanyi 2010-07-06 02:11:54 PDT
(In reply to comment #2)
> (From update of attachment 60510 [details])
> Does this match old-run-webkit-tests?  Why is Qt the only port which has noticed this? (Because other ports aren't using NRWT much yet?)

Yes, this behavior matches old-run-webkit-tests. Seems other ports don't use new-run-webkit-tests yet. The image hash is only used by pixel tests.
Comment 4 Csaba Osztrogonác 2010-07-06 02:18:28 PDT
(In reply to comment #2)
> (From update of attachment 60510 [details])
> Does this match old-run-webkit-tests?  Why is Qt the only port which has noticed this? (Because other ports aren't using NRWT much yet?)

ORWT only pass hash to DRT if pixel tests is enabled:
------
    # Try to read expected hash file for pixel tests
    my $suffixExpectedHash = "";
    if ($pixelTests && !$resetResults) {
        my $expectedPixelDir = expectedDirectoryForTest($base, 0, "png");
        if (open EXPECTEDHASH, "$expectedPixelDir/$base-$expectedTag.checksum") {
            my $expectedHash = <EXPECTEDHASH>;
            chomp($expectedHash);
            close EXPECTEDHASH;

            # Format expected hash into a suffix string that is appended to the path / URL passed to DRT
            $suffixExpectedHash = "'$expectedHash";
        }
    }
------
Comment 5 Eric Seidel (no email) 2010-07-06 02:27:45 PDT
Comment on attachment 60510 [details]
proposed patch

OK.  I suspect this is a regression since last time I tried NRWT then, since --platform=mac had pixel tests disabled when we were last using NRWT with it.
Comment 6 WebKit Commit Bot 2010-07-06 02:43:29 PDT
Comment on attachment 60510 [details]
proposed patch

Clearing flags on attachment: 60510

Committed r62541: <http://trac.webkit.org/changeset/62541>
Comment 7 WebKit Commit Bot 2010-07-06 02:43:34 PDT
All reviewed patches have been landed.  Closing bug.