Bug 41490 - Add missing operations to MacroAssemblerARMv7
Summary: Add missing operations to MacroAssemblerARMv7
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Gavin Barraclough
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-01 15:29 PDT by Gavin Barraclough
Modified: 2010-07-01 15:57 PDT (History)
1 user (show)

See Also:


Attachments
The patch (27.09 KB, patch)
2010-07-01 15:30 PDT, Gavin Barraclough
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Barraclough 2010-07-01 15:29:14 PDT
A number of operations (zeroDouble, set8, etc) that are present in other the ARM & X86 MacroAssemblers are missing from the ARMv7 port – add these.

Also, make single, double, quad register numbers in ARMv7Assembler distinct & strongly typed.
Comment 1 Gavin Barraclough 2010-07-01 15:30:30 PDT
Created attachment 60297 [details]
The patch
Comment 2 WebKit Review Bot 2010-07-01 15:31:17 PDT
Attachment 60297 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--no-squash']" exit_code: 1
JavaScriptCore/assembler/ARMv7Assembler.h:1264:  orr_S is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1272:  orr_S is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1496:  vadd_F64 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1501:  vcmp_F64 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1506:  vcvt_F64_S32 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1511:  vcvtr_S32_F64 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1516:  vdiv_F64 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1526:  vmov_F64_0 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1547:  vmul_F64 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
JavaScriptCore/assembler/ARMv7Assembler.h:1557:  vsub_F64 is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 10 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Oliver Hunt 2010-07-01 15:36:30 PDT
Comment on attachment 60297 [details]
The patch

r=me
Comment 4 Gavin Barraclough 2010-07-01 15:57:12 PDT
Sending        JavaScriptCore/ChangeLog
Sending        JavaScriptCore/assembler/ARMv7Assembler.h
Sending        JavaScriptCore/assembler/AbstractMacroAssembler.h
Sending        JavaScriptCore/assembler/MacroAssemblerARM.h
Sending        JavaScriptCore/assembler/MacroAssemblerARMv7.h
Sending        JavaScriptCore/assembler/MacroAssemblerMIPS.h
Sending        JavaScriptCore/assembler/MacroAssemblerX86Common.h
Transmitting file data .......
Committed revision 62306.