Bug 41474 - [Qt] fonts loaded via @font-face look bad
Summary: [Qt] fonts loaded via @font-face look bad
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-07-01 11:11 PDT by Bernhard Rosenkraenzer
Modified: 2010-07-02 03:46 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2010-07-01 11:11:13 PDT
Fonts loaded through the CSS3 @font-face mechanism look horrible on QtWebKit on Linux, see this page for an example:
http://blankpage.ch/webkitbug/

It looks ok in QtWebKit on OSX.
Comment 1 Bernhard Rosenkraenzer 2010-07-01 11:14:33 PDT
I just noticed it looks equally bad in Firefox on Linux, so probably the issue is with a lower level library used by both QtWebkit and Firefox (freetype?).

(Either that, or both call it with bad parameters like e.g. disabling all hinting)
Comment 2 Simon Hausmann 2010-07-02 03:46:28 PDT
Indeed, it looks bad to me on Firefox and Chrome under Linux, too. This is not a WebKit bug.