Bug 41377 - Change the copy location for Chromium's Mac layout test plugin
Summary: Change the copy location for Chromium's Mac layout test plugin
Status: RESOLVED DUPLICATE of bug 47850
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P2 Normal
Assignee: Stuart Morgan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-29 15:09 PDT by Stuart Morgan
Modified: 2010-10-19 14:22 PDT (History)
2 users (show)

See Also:


Attachments
Switch copy destination (1.18 KB, patch)
2010-06-29 16:18 PDT, Stuart Morgan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Morgan 2010-06-29 15:09:44 PDT
Chromium no longer needs to use an internal directory directory for test plugins, now that there's a --extra-plugin-dir argument, so we should start handling the layout plugin the same on the Mac as we do on the other platforms (which is to say, copy it to a plugins/ directory next to the application).
Comment 1 Stuart Morgan 2010-06-29 16:18:57 PDT
Created attachment 60070 [details]
Switch copy destination
Comment 2 Kent Tamura 2010-06-29 22:21:37 PDT
Chromium DumpRenderTree has no --extra-plugin-dir option.  So this patch won't work, right?
Comment 3 Stuart Morgan 2010-06-30 08:19:57 PDT
Doh, I wasn't thinking about this having a different launch infrastructure.

So would the right fix be to add that flag to the command line in SetUpTestEnvironmentImpl?
Comment 4 Kent Tamura 2010-06-30 18:37:33 PDT
(In reply to comment #3)
> So would the right fix be to add that flag to the command line in SetUpTestEnvironmentImpl?

I think so.
Comment 5 Tony Chang 2010-10-19 14:22:56 PDT
Fixed with 47850.

*** This bug has been marked as a duplicate of bug 47850 ***