We're currently using a dangerous way to differentiate between RenderSVGText / RenderSVGInlineText. We should better introduce a seperated isSVGInlineText(), to avoid confusion, and to be consistent with all other isFoo() functions.
(isFoo() means can be casted to RenderFoo, everywhere else)
Created attachment 59748 [details]
Created attachment 59750 [details]
Uploaded the wrong patch :( The second one is correct.
Landed in r61844.
http://trac.webkit.org/changeset/61844 might have broken GTK Linux 64-bit Debug
The following changes are on the blame list: