Spatial navigation does not work fine traversing nested iframe content as in [1]. [1] http://www.w3schools.com/TAGS/tryit.asp?filename=tryhtml_iframe patch coming ...
Created attachment 59656 [details] patch v1
(In reply to comment #1) > Created an attachment (id=59656) [details] > patch v1 @Simon, Kenneth: could any of you help with reviewing this patch?
Comment on attachment 59656 [details] patch v1 > +bool checkDescendenceRecursively(Document* baseDocument, Node* node) Check for what? I think this method name could be improved.
Thank you for the review. (In reply to comment #3) > (From update of attachment 59656 [details]) > > +bool checkDescendenceRecursively(Document* baseDocument, Node* node) > > Check for what? I think this method name could be improved. This method works like Node::isDescendantOf, but for nested documents. Basically, it checks if a given node is descendant of a given baseDocument. If it is not, it goes recursively up in the document chain checking if the current document is a descendant of baseDocument. Would you have a better name to suggest based on the description?
isDeepDescendantOf?
Created attachment 60056 [details] patch v2 - s/checkDescendanceRecursively/isDeepDescendantOf/ As per Simon suggestion, naming the added method as isDeepDescendantOf/
Created attachment 60062 [details] (r62179 - r=smfr) patch v2.1 - right patch
Comment on attachment 60062 [details] (r62179 - r=smfr) patch v2.1 - right patch Since this addition is a function, not a method, the name should be more like isNodeDeepDescendentOfDocument(), or perhaps documentTreeContainsNode(). r=me either way.
Comment on attachment 60062 [details] (r62179 - r=smfr) patch v2.1 - right patch Clearing flags on attachment: 60062 Committed r62179: <http://trac.webkit.org/changeset/62179>
(In reply to comment #8) > (From update of attachment 60062 [details]) > Since this addition is a function, not a method, the name should be more like isNodeDeepDescendentOfDocument(), or perhaps documentTreeContainsNode(). > > r=me either way. I used the former. Thank you!
Revision r62179 cherry-picked into qtwebkit-2.0 with commit 18375caeaf6b2cf99c45e1b225e23c6028e1dd68