Bug 41011 - Incremental build failed on Chromium ews
Summary: Incremental build failed on Chromium ews
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Other
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 5861
  Show dependency treegraph
 
Reported: 2010-06-22 13:43 PDT by Zoltan Herczeg
Modified: 2010-07-19 11:13 PDT (History)
5 users (show)

See Also:


Attachments
Patch (1.57 KB, patch)
2010-06-25 11:10 PDT, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Herczeg 2010-06-22 13:43:57 PDT
In this bug, the ews bot incorrectly reports an error, which is not happen for clean builds:
https://bugs.webkit.org/show_bug.cgi?id=5861

Probably the incremental build fails. Can we force a clean build on patches?
Comment 1 Zoltan Herczeg 2010-06-25 06:17:45 PDT
Evan please help.
Comment 2 Evan Martin 2010-06-25 10:30:52 PDT
EWS masters, can we do clean builds on the EWS?
Comment 3 Dimitri Glazkov (Google) 2010-06-25 10:42:22 PDT
Will clean up in a sec. #webkit is also a good venue for this.
Comment 4 Adam Barth 2010-06-25 10:44:38 PDT
The problem is that build-webkit --chromium doesn't understand how to deal with changes to WebCore/WebCore.gypi.
Comment 5 Dimitri Glazkov (Google) 2010-06-25 10:46:24 PDT
(In reply to comment #3)
> Will clean up in a sec. #webkit is also a good venue for this.

Apologies, I don't know how to read. As punishment, adding myself to Skipped tests lists.
Comment 6 Adam Barth 2010-06-25 11:10:44 PDT
Created attachment 59780 [details]
Patch
Comment 7 Adam Barth 2010-06-25 12:55:08 PDT
Let see how badly this borks things.
Comment 8 Adam Barth 2010-06-25 12:57:28 PDT
Comment on attachment 59780 [details]
Patch

Clearing flags on attachment: 59780

Committed r61883: <http://trac.webkit.org/changeset/61883>
Comment 9 Adam Barth 2010-06-25 12:57:34 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Zoltan Herczeg 2010-06-28 04:33:36 PDT
This patch do miracles! Excellent work guys :)
Comment 11 Tony Chang 2010-07-19 10:53:12 PDT
This patch is kind of annoying.  Every time I run build-webkit --chromium, gclient runs.  Is it not possible to modify just the ews bot step instead of modifying build-webkit?

The other option is to make a build-webkit --chromium --force, and have --force trigger gclient.

Also, on this slows down the waterfall bots because now we run gclient twice (once during the update chromium dependencies step and once during the compile step).
Comment 12 Adam Barth 2010-07-19 11:13:26 PDT
Maybe the solution is better dependency checking?  Other ports pick up changes to their build system when you run build-webkit.