Bug 40715 - xsltProcessor.transformToFragment returning NULL (in Safari, Chrome)
Summary: xsltProcessor.transformToFragment returning NULL (in Safari, Chrome)
Status: RESOLVED DUPLICATE of bug 10313
Alias: None
Product: WebKit
Classification: Unclassified
Component: XML (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: https://zd1.zednax.com:9443/saxon_tes...
Depends on:
Reported: 2010-06-16 09:28 PDT by Liam Foy
Modified: 2010-06-16 11:46 PDT (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Liam Foy 2010-06-16 09:28:01 PDT

The following code works in FireFox:


and here are the XSL files:


The problem seems to be this line:

resultDocument = xsltProcessor.transformToFragment(xml,document);

in Safari 5 and Chrome.

We have also used saxon8 which correctly transforms on the command line.

If you require any more information please let us know!
Comment 1 Alexey Proskuryakov 2010-06-16 11:18:36 PDT

*** This bug has been marked as a duplicate of bug 10313 ***
Comment 2 Liam Foy 2010-06-16 11:35:48 PDT
I'll admit I don't fully understand the problem in 10313. This is a very old bug if related. Is there any work around?
Comment 3 Alexey Proskuryakov 2010-06-16 11:45:34 PDT
The only workaround is to load the document to be transformed in a frame.
Comment 4 Alexey Proskuryakov 2010-06-16 11:46:14 PDT
(or to not use xsl:import and document(), of course)