Bug 40625 - Fix compilation when filters are disabled
: Fix compilation when filters are disabled
Status: RESOLVED FIXED
: WebKit
SVG
: 528+ (Nightly build)
: Other All
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2010-06-15 08:29 PST by
Modified: 2011-06-09 20:49 PST (History)


Attachments
Patch (1.31 KB, patch)
2010-06-15 08:30 PST, Lucas De Marchi
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-06-15 08:29:53 PST
Fix compilation when filters are disabled
------- Comment #1 From 2010-06-15 08:30:57 PST -------
Created an attachment (id=58781) [details]
Patch
------- Comment #2 From 2010-06-15 08:37:33 PST -------
Adding people in CC responsible for r60689.

The error was:

WebCore/rendering/SVGRenderSupport.cpp: In static member function ‘static bool WebCore::SVGRenderBase::prepareToRenderSVGContent(WebCore::RenderObject*, WebCore::RenderObject::PaintInfo&, const WebCore::FloatRect&, WebCore::RenderSVGResourceFilter*&)’:
WebCore/rendering/SVGRenderSupport.cpp:89:5: error: ‘rootFilter’ was not declared in this scope
------- Comment #3 From 2010-06-18 03:41:41 PST -------
(From update of attachment 58781 [details])
Clearing flags on attachment: 58781

Committed r61392: <http://trac.webkit.org/changeset/61392>
------- Comment #4 From 2010-06-18 03:41:47 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #5 From 2010-06-18 04:02:10 PST -------
*** Bug 40822 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2011-06-09 20:49:21 PST -------
(From update of attachment 58781 [details])
Mark patch as obsolete